We are continuing to monitor for any further issues.
Posted Jun 01, 2026 - 11:35 UTC
Update
**Image Count Update**
We are pleased to confirm that the image count issue has now been fully resolved.
The previously deployed fix addressed all new cases and image uploads, and we have now completed the backfill of historical data. Image counts should therefore be displaying correctly across all cases.
We will continue to monitor the platform closely to ensure everything remains stable before formally closing the incident.
Thank you for your patience and understanding throughout this process.
Posted Jun 01, 2026 - 11:34 UTC
Update
**Image Count Update**
A fix has now been deployed which resolves the image count issue for all new cases and for any existing cases where new images are subsequently added.
We are currently working on backfilling the historical data to ensure image counts are correctly reflected across all existing cases. This work is ongoing and does not affect the underlying images or associated data, all of which remain fully accessible.
We will provide a further update once the historical backfill has been completed.
Posted Jun 01, 2026 - 09:55 UTC
Monitoring
Following the issues experienced on Friday, we are pleased to confirm that all core services are operating normally and all data is present and accessible.
We are aware of a remaining issue whereby image counts displayed in certain areas of the user interface may not accurately reflect the actual number of images associated with a case. This is a UI display issue only and does not affect the underlying data, images, or any API functionality. All APIs continue to operate normally and are unaffected.
The cause has been identified and a fix is currently being deployed. We will provide a further update once this has been completed.
Thank you for your patience and continued support.